Posted in 2016

Installing RAC on OEL 7.2

There are some changes in OEL 7.2, the udev is working other and also firewalld is new.. Always new things.. a Sysadmin has a bad life too.. always learning new things, bad developers.

1.yum install oracle-rdbms-server-12cR1-preinstall-1.0-4.el7.x86_64
2. after installing all things make user modifications.
[root@rac1 ~]# groupadd asmadmin 
[root@rac1 ~]# groupadd asmdba
[root@rac1 ~]# usermod -a -G asmdba oracle
[root@rac1 ~]# id oracle
uid=54321(oracle) gid=54321(oinstall) groups=54321(oinstall),54322(dba),54324(asmdba)
[root@rac1 ~]# useradd -g oinstall -G asmadmin,asmdba grid
[root@rac1 ~]# id grid
uid=54322(grid) gid=54321(oinstall) groups=54321(oinstall),54323(asmadmin),54324(asmdba)
[root@rac1 ~]# mkdir -p /products/grid/12.1.0.2
[root@rac1 ~]# mkdir -p /products/oracle/12.1.0.2
[root@rac1 ~]# chown -R grid:oinstall /products/
[root@rac1 ~]# chown -R oracle:oinstall /products/oracle/
[root@rac1 ~]# chmod -R 775 /products/
[root@rac1 rpm]# yum localinstall cvuqdisk-1.0.9-1.rpm 
[root@rac1 rpm]# cat /etc/udev/rules.d/99-oracle.rules 
KERNEL=="sd?1", SUBSYSTEM=="block", PROGRAM=="/usr/lib/udev/scsi_id -g -u -d /dev/$parent", RESULT=="1ATA_VBOX_HARDDISK_VB2709a858-60625687", SYMLINK+="asm-disk1", OWNER="grid", GROUP="asmadmin", MODE="0660"
KERNEL=="sd?1", SUBSYSTEM=="block", PROGRAM=="/usr/lib/udev/scsi_id -g -u -d /dev/$parent", RESULT=="1ATA_VBOX_HARDDISK_VBf189f74c-ae118012", SYMLINK+="asm-disk2", OWNER="grid", GROUP="asmadmin", MODE="0660"
KERNEL=="sd?1", SUBSYSTEM=="block", PROGRAM=="/usr/lib/udev/scsi_id -g -u -d /dev/$parent", RESULT=="1ATA_VBOX_HARDDISK_VB8e629c0a-30334875", SYMLINK+="asm-disk3", OWNER="grid", GROUP="asmadmin", MODE="0660"
[root@rac1 ~]# usermod -a -G vboxsf grid
[root@rac1 ~]# usermod -a -G vboxsf oracle
Advertisements